re = /^(.\s?)(\d{2}\s?)(\d{1})(.?\s)(\d{3}.?)(\d{4})$/m
str = '+63 2 123 4567
+632 456-7890
+632 4567890
(632) 987 6543'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end