$re = '/^(.\s?)(\d{2}\s?)(\d{1})(.?\s)(\d{3}.?)(\d{4})$/m';
$str = '+63 2 123 4567
+632 456-7890
+632 4567890
(632) 987 6543';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);