package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.\s?)(\d{2}\s?)(\d{1})(.?\s)(\d{3}.?)(\d{4})$`)
var str = `+63 2 123 4567
+632 456-7890
+632 4567890
(632) 987 6543`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}