# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?!^\*)+?(?:^\W*\r*)(?<country>[\w]{0,1}[^\r\n])(?:[^\w*]+)(?<channel>[\w?,'\"\-_ ]*(?<![^\w?!])).*?(?<tag>\w*$)|(?<channel2>^[\w?,'\"\-_]+(?<![^\w?!]))[^\w\r\n\*\t\f\v]*(?<tag2>\w+$)?"
test_str = ("*** jeo ****\n"
"UK -+- \"Channel Name' | HD\n"
"Channel | FHD\n"
"zeebo\n"
"BBC\n"
"US = LONG chanell NaME | FHD\n"
"US - SkySports | HD\n"
"ES | Chan-nel Name HD\n"
"IT| My long super channel Name | HD\n"
"ks lets sae my channel | hd\n"
"JS: My channel Name | HD\n"
"JS: Sky Cinema Action\n"
"UK: Sky Cinema Gold | FHD\n"
"JA: Some other channel :HD\n"
"UK: this channel name ||jdh\n"
"AH: does it work for all?? |HD\n"
"UJ: Dont call me dave\n"
"****** My service Provider\n"
"DE: Doesn't handle weird _String | FHD\n"
"UK: so howcanedo | HD\n"
"KD: 5g0fff9 98hf9 ?|FHD\n"
"UR: this is okay mostly | FHD\n"
"EE) but does it always work? | vip\n"
"****** My service Provider ****vip\n"
"re: hahahaahahaahahaha 32 hd | hd\n"
"jg: will it work | dd\n"
"ur: rte1 | FHD\n"
"IR: M-Y CHAN-NEL NAME |VIP\n"
"IR: MY CHANNEL NAME | FHD\n"
"le let me get this channel\" |FHD\n"
"UK MY CHANNNEL NAME | FHD\n"
"el haha get my name | jfh")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.