const regex = /(?!^\*)+?(?:^\W*\r*)(?<country>[\w]{0,1}[^\r\n])(?:[^\w*]+)(?<channel>[\w?,'\"\-_ ]*(?<![^\w?!])).*?(?<tag>\w*$)|(?<channel2>^[\w?,'\"\-_]+(?<![^\w?!]))[^\w\r\n\*\t\f\v]*(?<tag2>\w+$)?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^\\*)+?(?:^\\W*\\r*)(?<country>[\\w]{0,1}[^\\r\\n])(?:[^\\w*]+)(?<channel>[\\w?,\'\\"\\-_ ]*(?<![^\\w?!])).*?(?<tag>\\w*$)|(?<channel2>^[\\w?,\'\\"\\-_]+(?<![^\\w?!]))[^\\w\\r\\n\\*\\t\\f\\v]*(?<tag2>\\w+$)?', 'mg')
const str = `*** jeo ****
UK -+- "Channel Name' | HD
Channel | FHD
zeebo
BBC
US = LONG chanell NaME | FHD
US - SkySports | HD
ES | Chan-nel Name HD
IT| My long super channel Name | HD
ks lets sae my channel | hd
JS: My channel Name | HD
JS: Sky Cinema Action
UK: Sky Cinema Gold | FHD
JA: Some other channel :HD
UK: this channel name ||jdh
AH: does it work for all?? |HD
UJ: Dont call me dave
****** My service Provider
DE: Doesn't handle weird _String | FHD
UK: so howcanedo | HD
KD: 5g0fff9 98hf9 ?|FHD
UR: this is okay mostly | FHD
EE) but does it always work? | vip
****** My service Provider ****vip
re: hahahaahahaahahaha 32 hd | hd
jg: will it work | dd
ur: rte1 | FHD
IR: M-Y CHAN-NEL NAME |VIP
IR: MY CHANNEL NAME | FHD
le let me get this channel" |FHD
UK MY CHANNNEL NAME | FHD
el haha get my name | jfh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}