#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^\*)+?(?:^\W*\r*)(?<country>[\w]{0,1}[^\r\n])(?:[^\w*]+)(?<channel>[\w?,'\"\-_ ]*(?<![^\w?!])).*?(?<tag>\w*$)|(?<channel2>^[\w?,'\"\-_]+(?<![^\w?!]))[^\w\r\n\*\t\f\v]*(?<tag2>\w+$)?"
Local $sString = "*** jeo ****" & @CRLF & _
"UK -+- "Channel Name' | HD" & @CRLF & _
"Channel | FHD" & @CRLF & _
"zeebo" & @CRLF & _
"BBC" & @CRLF & _
"US = LONG chanell NaME | FHD" & @CRLF & _
"US - SkySports | HD" & @CRLF & _
"ES | Chan-nel Name HD" & @CRLF & _
"IT| My long super channel Name | HD" & @CRLF & _
"ks lets sae my channel | hd" & @CRLF & _
"JS: My channel Name | HD" & @CRLF & _
"JS: Sky Cinema Action" & @CRLF & _
"UK: Sky Cinema Gold | FHD" & @CRLF & _
"JA: Some other channel :HD" & @CRLF & _
"UK: this channel name ||jdh" & @CRLF & _
"AH: does it work for all?? |HD" & @CRLF & _
"UJ: Dont call me dave" & @CRLF & _
"****** My service Provider" & @CRLF & _
"DE: Doesn't handle weird _String | FHD" & @CRLF & _
"UK: so howcanedo | HD" & @CRLF & _
"KD: 5g0fff9 98hf9 ?|FHD" & @CRLF & _
"UR: this is okay mostly | FHD" & @CRLF & _
"EE) but does it always work? | vip" & @CRLF & _
"****** My service Provider ****vip" & @CRLF & _
"re: hahahaahahaahahaha 32 hd | hd" & @CRLF & _
"jg: will it work | dd" & @CRLF & _
"ur: rte1 | FHD" & @CRLF & _
"IR: M-Y CHAN-NEL NAME |VIP" & @CRLF & _
"IR: MY CHANNEL NAME | FHD" & @CRLF & _
"le let me get this channel" |FHD" & @CRLF & _
"UK MY CHANNNEL NAME | FHD" & @CRLF & _
"el haha get my name | jfh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")