const regex = new RegExp('(?P<output>.*)\\s(?P<active>\\w*connected)', '')
const str = `HDMI-1 disconnected (normal left inverted right x axis y axis)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}