using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<output>.*)\s(?P<active>\w*connected)";
string input = @"HDMI-1 disconnected (normal left inverted right x axis y axis)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}