package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<output>.*)\s(?P<active>\w*connected)`)
var str = `HDMI-1 disconnected (normal left inverted right x axis y axis)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}