const regex = /(^\d{1,3}((\s|-))?\(?\d\d\d\)?|^\(?\d\d\d\)?)((\s|-))?\d\d\d((\s|-))?\d\d\d\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\d{1,3}((\\s|-))?\\(?\\d\\d\\d\\)?|^\\(?\\d\\d\\d\\)?)((\\s|-))?\\d\\d\\d((\\s|-))?\\d\\d\\d\\d$', 'gm')
const str = `// These Should Work
1 123 321 1234
1 (123-321-1234
11233211234
1(123)321-1234
123-321-1234
1-123321-1234
1(123321-1234
// These Should Not
1111 123-321-1234
1 123 32112-34
1(123) -321-1234
1(123321123-4
12345678901234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}