#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\d{1,3}((\s|-))?\(?\d\d\d\)?|^\(?\d\d\d\)?)((\s|-))?\d\d\d((\s|-))?\d\d\d\d$"
Local $sString = "// These Should Work" & @CRLF & _
" " & @CRLF & _
"1 123 321 1234" & @CRLF & _
"1 (123-321-1234" & @CRLF & _
"11233211234" & @CRLF & _
"1(123)321-1234" & @CRLF & _
"123-321-1234" & @CRLF & _
"" & @CRLF & _
"1-123321-1234" & @CRLF & _
"1(123321-1234" & @CRLF & _
"" & @CRLF & _
"// These Should Not" & @CRLF & _
"" & @CRLF & _
"1111 123-321-1234 " & @CRLF & _
"1 123 32112-34" & @CRLF & _
"1(123) -321-1234" & @CRLF & _
"1(123321123-4" & @CRLF & _
"12345678901234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")