package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\d{1,3}((\s|-))?\(?\d\d\d\)?|^\(?\d\d\d\)?)((\s|-))?\d\d\d((\s|-))?\d\d\d\d$`)
var str = `// These Should Work
1 123 321 1234
1 (123-321-1234
11233211234
1(123)321-1234
123-321-1234
1-123321-1234
1(123321-1234
// These Should Not
1111 123-321-1234
1 123 32112-34
1(123) -321-1234
1(123321123-4
12345678901234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}