// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mui)(,|\r?\n|\r|^)(?:"([^"]*(?:""[^"]*)*)"|([^",\r\n]*))"#).unwrap();
let string = "\"1\",\"test\",\"booth\",\"\",\"2024/09/11\",\"2024/08/20\",\"1000\",\"2000\",\"\",\"1\",\"プレミアムウォーター\",\"0\",\"\",\"\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}