using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,|\r?\n|\r|^)(?:""([^""]*(?:""[^""]*)*)""|([^"",\r\n]*))";
string input = @"""1"",""test"",""booth"","",""2024/09/11"",""2024/08/20"",""1000"",""2000"","",""1"",""プレミアムウォーター"",""0"","",""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}