$re = '/(,|\r?\n|\r|^)(?:"([^"]*(?:""[^"]*)*)"|([^",\r\n]*))/mui';
$str = '"1","test","booth","","2024/09/11","2024/08/20","1000","2000","","1","プレミアムウォーター","0","",""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);