use strict;
my $str = '20220623-19563352
20220623-18261367
20220606-15484894
20220606-15484
20220606
20220606-15
202206
33333333-33333333333
5453345345345353434646
3463334334535
202206a
2022067-+';
my $regex = qr/^[0-9-]{0,8}([-][0-9-]{0,8})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}