using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9-]{0,8}([-][0-9-]{0,8})?$";
string input = @"20220623-19563352
20220623-18261367
20220606-15484894
20220606-15484
20220606
20220606-15
202206
33333333-33333333333
5453345345345353434646
3463334334535
202206a
2022067-+";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}