import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9-]{0,8}([-][0-9-]{0,8})?$";
final String string = "20220623-19563352\n"
+ "20220623-18261367\n"
+ "20220606-15484894\n"
+ "20220606-15484\n"
+ "20220606\n"
+ "20220606-15\n"
+ "202206\n"
+ "33333333-33333333333\n"
+ "5453345345345353434646\n"
+ "3463334334535\n"
+ "202206a\n"
+ "2022067-+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}