const regex = new RegExp('(?ix)(?:^[A-Z\\W]*\\W+(?!bnd|cnr)\\W+)?(?:(?!\\b(?:RD|HWY|TRAIL|St|R)\\b)(?P<numbers>\\d+-\\d+|\\d+[A-Z]?)\\W+)*?(?:\\W+(?:AND|&)\\W+)*(?:(?:(?P<geo>BND|CNR)(?:\\WOF|\\WBY)?)\\W+)*(?P<name>(?:(?!\\b(?:RD|HWY|TRAIL|St|R)\\b)[A-Z]+\\W*)+)\\W+(?:(?P<type>RD|HWY|TRAIL|St|R)\\W)+', 'g')
const str = `convention centre, bnd by swanston st and avoca st
cnr the hyatt and roland st 123 hudson st BND BY THOMAS RAIL TRAIL, 7 SNOW WHITE HWY & MICKEY RD, 337-343 BOGEYMAN RD, 4, 8, 9-13, 16-18 Fictional Rd & 17B Elm St near junction`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}