#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)(?:^[A-Z\W]*\W+(?!bnd|cnr)\W+)?(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)(?P<numbers>\d+-\d+|\d+[A-Z]?)\W+)*?(?:\W+(?:AND|&)\W+)*(?:(?:(?P<geo>BND|CNR)(?:\WOF|\WBY)?)\W+)*(?P<name>(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)[A-Z]+\W*)+)\W+(?:(?P<type>RD|HWY|TRAIL|St|R)\W)+"
Local $sString = "convention centre, bnd by swanston st and avoca st" & @CRLF & _
"cnr the hyatt and roland st 123 hudson st BND BY THOMAS RAIL TRAIL, 7 SNOW WHITE HWY & MICKEY RD, 337-343 BOGEYMAN RD, 4, 8, 9-13, 16-18 Fictional Rd & 17B Elm St near junction"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")