import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ix)(?:^[A-Z\\W]*\\W+(?!bnd|cnr)\\W+)?(?:(?!\\b(?:RD|HWY|TRAIL|St|R)\\b)(?P<numbers>\\d+-\\d+|\\d+[A-Z]?)\\W+)*?(?:\\W+(?:AND|&)\\W+)*(?:(?:(?P<geo>BND|CNR)(?:\\WOF|\\WBY)?)\\W+)*(?P<name>(?:(?!\\b(?:RD|HWY|TRAIL|St|R)\\b)[A-Z]+\\W*)+)\\W+(?:(?P<type>RD|HWY|TRAIL|St|R)\\W)+";
final String string = "convention centre, bnd by swanston st and avoca st\n"
+ "cnr the hyatt and roland st 123 hudson st BND BY THOMAS RAIL TRAIL, 7 SNOW WHITE HWY & MICKEY RD, 337-343 BOGEYMAN RD, 4, 8, 9-13, 16-18 Fictional Rd & 17B Elm St near junction";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}