// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)proc_notes_(January|February|March|April|May|June|July|August|September|October|November|December)\d{4}.txt").unwrap();
let string = "proc_notes_April2020.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}