re = /proc_notes_(January|February|March|April|May|June|July|August|September|October|November|December)\d{4}.txt/m
str = 'proc_notes_April2020.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end