using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"proc_notes_(January|February|March|April|May|June|July|August|September|October|November|December)\d{4}.txt";
string input = @"proc_notes_April2020.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}