$re = '/https?:\/\/(?:www\.)?ikea\.co\.id\/in/';
$str = 'https://www.ikea.co.id/in';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);