using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(?:www\.)?ikea\.co\.id\/in";
string input = @"https://www.ikea.co.id/in";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}