package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/(?:www\.)?ikea\.co\.id\/in`)
var str = `https://www.ikea.co.id/in`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}