// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?\:\/\/)?(www\.)?([a-z0-9]([a-z0-9]|(\-[a-z0-9]))*\.)+[a-z]+(\/[\-a-z_]+)*(\/[a-z]+\.(jpg|png|jpeg|JPG|PNG|JPEG){1})").unwrap();
let string = "http://www.laweb.es/ruta_a_la-url/delaimagen.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}