package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?\:\/\/)?(www\.)?([a-z0-9]([a-z0-9]|(\-[a-z0-9]))*\.)+[a-z]+(\/[\-a-z_]+)*(\/[a-z]+\.(jpg|png|jpeg|JPG|PNG|JPEG){1})`)
var str = `http://www.laweb.es/ruta_a_la-url/delaimagen.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}