const regex = /(https?\:\/\/)?(www\.)?([a-z0-9]([a-z0-9]|(\-[a-z0-9]))*\.)+[a-z]+(\/[\-a-z_]+)*(\/[a-z]+\.(jpg|png|jpeg|JPG|PNG|JPEG){1})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?\\:\\\/\\\/)?(www\\.)?([a-z0-9]([a-z0-9]|(\\-[a-z0-9]))*\\.)+[a-z]+(\\\/[\\-a-z_]+)*(\\\/[a-z]+\\.(jpg|png|jpeg|JPG|PNG|JPEG){1})', 'g')
const str = `http://www.laweb.es/ruta_a_la-url/delaimagen.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}