# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.+\/(.+?)[\W|$]"
test_str = ("/var/log/audit/audit.log\n"
"/var/log/audit/audit.log.1\n"
"/var/log/boot.log\n"
"/var/log/btmp\n"
"/var/log/btmp-20170401\n"
"/var/log/chrony\n"
"/var/log/cron\n"
"/var/log/cron-20170326\n"
"/var/log/cron-20170402\n"
"/var/log/cron-20170410\n"
"/var/log/cron-20170416\n"
"/var/log/anaconda\n"
"./var/log/anaconda/anaconda.log\n"
"./var/log/anaconda/ifcfg.log\n"
"./var/log/anaconda/journal.log\n"
"./var/log/anaconda/ks-script-XcavhD.log\n"
"./var/log/anaconda/packaging.log\n"
"./var/log/anaconda/program.log\n"
"./var/log/anaconda/storage.log\n"
"./var/log/anaconda/syslog\n"
"./var/log/anaconda/X.log\n"
"./var/log/audit\n"
"./var/log/audit/audit.log\n"
"./var/log/audit/audit.log.1\n\n"
"/var/log/httpd/error_log;\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.