import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+\\/(.+?)[\\W|$]";
final String string = "/var/log/audit/audit.log\n"
+ "/var/log/audit/audit.log.1\n"
+ "/var/log/boot.log\n"
+ "/var/log/btmp\n"
+ "/var/log/btmp-20170401\n"
+ "/var/log/chrony\n"
+ "/var/log/cron\n"
+ "/var/log/cron-20170326\n"
+ "/var/log/cron-20170402\n"
+ "/var/log/cron-20170410\n"
+ "/var/log/cron-20170416\n"
+ "/var/log/anaconda\n"
+ "./var/log/anaconda/anaconda.log\n"
+ "./var/log/anaconda/ifcfg.log\n"
+ "./var/log/anaconda/journal.log\n"
+ "./var/log/anaconda/ks-script-XcavhD.log\n"
+ "./var/log/anaconda/packaging.log\n"
+ "./var/log/anaconda/program.log\n"
+ "./var/log/anaconda/storage.log\n"
+ "./var/log/anaconda/syslog\n"
+ "./var/log/anaconda/X.log\n"
+ "./var/log/audit\n"
+ "./var/log/audit/audit.log\n"
+ "./var/log/audit/audit.log.1\n\n"
+ "/var/log/httpd/error_log;\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}