#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+\/(.+?)[\W|$]"
Local $sString = "/var/log/audit/audit.log" & @CRLF & _
"/var/log/audit/audit.log.1" & @CRLF & _
"/var/log/boot.log" & @CRLF & _
"/var/log/btmp" & @CRLF & _
"/var/log/btmp-20170401" & @CRLF & _
"/var/log/chrony" & @CRLF & _
"/var/log/cron" & @CRLF & _
"/var/log/cron-20170326" & @CRLF & _
"/var/log/cron-20170402" & @CRLF & _
"/var/log/cron-20170410" & @CRLF & _
"/var/log/cron-20170416" & @CRLF & _
"/var/log/anaconda" & @CRLF & _
"./var/log/anaconda/anaconda.log" & @CRLF & _
"./var/log/anaconda/ifcfg.log" & @CRLF & _
"./var/log/anaconda/journal.log" & @CRLF & _
"./var/log/anaconda/ks-script-XcavhD.log" & @CRLF & _
"./var/log/anaconda/packaging.log" & @CRLF & _
"./var/log/anaconda/program.log" & @CRLF & _
"./var/log/anaconda/storage.log" & @CRLF & _
"./var/log/anaconda/syslog" & @CRLF & _
"./var/log/anaconda/X.log" & @CRLF & _
"./var/log/audit" & @CRLF & _
"./var/log/audit/audit.log" & @CRLF & _
"./var/log/audit/audit.log.1" & @CRLF & _
"" & @CRLF & _
"/var/log/httpd/error_log;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")