const regex = new RegExp('(?i)incident:(\\w.*),eid:(\\w.*),domain:(\\w.*),contact:(\\w.*)', 'gm')
const str = `incident:reset my password,eid:emmanuel.z.m.deluyas,domain:accenture@com,contact:09668674472`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}