package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)incident:(\w.*),eid:(\w.*),domain:(\w.*),contact:(\w.*)`)
var str = `incident:reset my password,eid:emmanuel.z.m.deluyas,domain:accenture@com,contact:09668674472`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}