import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)incident:(\\w.*),eid:(\\w.*),domain:(\\w.*),contact:(\\w.*)";
final String string = "incident:reset my password,eid:emmanuel.z.m.deluyas,domain:accenture@com,contact:09668674472";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}