$re = '/(?<!\S)(?P<set>
(?:(?P<a>A) | (?P<b>B) | (?P<c>C))
(?:
(?(a) (?!A))
(?(b) (?!B))
(?(c) (?!C))
(?&set)
)?
)\s/mx';
$str = 'ABC ACB AB AC
BAC BCA BA BC
CAB CBA CA CB
A B C
AA BB CC
ABD ACD
BAD BCD
CAD CBD
AAA AAB ABA BAA AAC ACA CAA
BBB BBA BAB ABB BBC BCB CBB
CCC CCA CAC ACC CCB CBC BCC
ABCA ABCB ABCC ABCX ABCY ABCZ
ACBA ACBB ACBC ACBX ACBY ACBZ
BACA BACB BACC BACX BACY BACZ
BCAA BCAB BCAC BCAX BCAY BCAZ
CABA CABB CABC CABX CABY CABZ
CBAA CBAB CBAC CBAX CBAY CBAZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);