import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?P<set>\n"
+ " (?:(?P<a>A) | (?P<b>B) | (?P<c>C))\n"
+ " (?:\n"
+ " (?(a) (?!A))\n"
+ " (?(b) (?!B))\n"
+ " (?(c) (?!C))\n"
+ " (?&set)\n"
+ " )?\n"
+ ")\\s";
final String string = "ABC ACB AB AC\n"
+ "BAC BCA BA BC\n"
+ "CAB CBA CA CB\n\n"
+ "A B C\n\n"
+ "AA BB CC\n"
+ "ABD ACD\n"
+ "BAD BCD\n"
+ "CAD CBD\n"
+ "AAA AAB ABA BAA AAC ACA CAA\n"
+ "BBB BBA BAB ABB BBC BCB CBB\n"
+ "CCC CCA CAC ACC CCB CBC BCC\n"
+ "ABCA ABCB ABCC ABCX ABCY ABCZ\n"
+ "ACBA ACBB ACBC ACBX ACBY ACBZ\n"
+ "BACA BACB BACC BACX BACY BACZ\n"
+ "BCAA BCAB BCAC BCAX BCAY BCAZ\n"
+ "CABA CABB CABC CABX CABY CABZ\n"
+ "CBAA CBAB CBAC CBAX CBAY CBAZ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}