use strict;
my $str = 'ABC ACB AB AC
BAC BCA BA BC
CAB CBA CA CB
A B C
AA BB CC
ABD ACD
BAD BCD
CAD CBD
AAA AAB ABA BAA AAC ACA CAA
BBB BBA BAB ABB BBC BCB CBB
CCC CCA CAC ACC CCB CBC BCC
ABCA ABCB ABCC ABCX ABCY ABCZ
ACBA ACBB ACBC ACBX ACBY ACBZ
BACA BACB BACC BACX BACY BACZ
BCAA BCAB BCAC BCAX BCAY BCAZ
CABA CABB CABC CABX CABY CABZ
CBAA CBAB CBAC CBAX CBAY CBAZ';
my $regex = qr/(?<!\S)(?P<set>
(?:(?P<a>A) | (?P<b>B) | (?P<c>C))
(?:
(?(a) (?!A))
(?(b) (?!B))
(?(c) (?!C))
(?&set)
)?
)\s/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}