const regex = /(http|https):\/\/www.example\.com\/holidays\/(.*)-holidays\.html/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|https):\\\/\\\/www.example\\.com\\\/holidays\\\/(.*)-holidays\\.html', 'gm')
const str = `https://www.example.com/halkidiki-holidays.html
https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html
https://www.example.com/holidays/abano-terme-holidays.html
https://www.example.com/holidays/crete/hersonissos/hotel-lovely-holidays.html
https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html
https://www.example.com/halkidiki-holidays.html
https://www.example.com/holidays/abano%20terme-holidays.html
https://www.example.com/holidays/abano-terme-holidays.html
https://www.example.com/holidays/abu-dhabi-all-inclusive-holidays.html
https://www.example.com/holidays/abu-dhabi-holidays.html
https://www.example.com/holidays/abu-soma-holidays.html
https://www.example.com/holidays/acharavi-holidays.html
https://www.example.com/holidays/achladies-holidays.html
https://www.example.com/holidays/aci-castello-holidays.html
https://www.example.com/holidays/acireale-holidays.html
https://www.example.com/holidays/acoteias-holidays.html
https://www.example.com/holidays/adana-holidays.html
https://www.example.com/holidays/adelianos-kampos-holidays.html
https://www.example.com/holidays/aegean-coast-holidays.html
https://www.example.com/holidays/afandou-holidays.html
https://www.example.com/holidays/afitos-holidays.html
https://www.example.com/holidays/africa-holidays.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}