#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http|https):\/\/www.example\.com\/holidays\/(.*)-holidays\.html"
Local $sString = "https://www.example.com/halkidiki-holidays.html" & @CRLF & _
"https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html" & @CRLF & _
"https://www.example.com/holidays/abano-terme-holidays.html" & @CRLF & _
"https://www.example.com/holidays/crete/hersonissos/hotel-lovely-holidays.html" & @CRLF & _
"https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html" & @CRLF & _
"https://www.example.com/halkidiki-holidays.html" & @CRLF & _
"https://www.example.com/holidays/abano%20terme-holidays.html" & @CRLF & _
"https://www.example.com/holidays/abano-terme-holidays.html" & @CRLF & _
"https://www.example.com/holidays/abu-dhabi-all-inclusive-holidays.html" & @CRLF & _
"https://www.example.com/holidays/abu-dhabi-holidays.html" & @CRLF & _
"https://www.example.com/holidays/abu-soma-holidays.html" & @CRLF & _
"https://www.example.com/holidays/acharavi-holidays.html" & @CRLF & _
"https://www.example.com/holidays/achladies-holidays.html" & @CRLF & _
"https://www.example.com/holidays/aci-castello-holidays.html" & @CRLF & _
"https://www.example.com/holidays/acireale-holidays.html" & @CRLF & _
"https://www.example.com/holidays/acoteias-holidays.html" & @CRLF & _
"https://www.example.com/holidays/adana-holidays.html" & @CRLF & _
"https://www.example.com/holidays/adelianos-kampos-holidays.html" & @CRLF & _
"https://www.example.com/holidays/aegean-coast-holidays.html" & @CRLF & _
"https://www.example.com/holidays/afandou-holidays.html" & @CRLF & _
"https://www.example.com/holidays/afitos-holidays.html" & @CRLF & _
"https://www.example.com/holidays/africa-holidays.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")