import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https):\\/\\/www.example\\.com\\/holidays\\/(.*)-holidays\\.html";
final String string = "https://www.example.com/halkidiki-holidays.html\n"
+ "https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html\n"
+ "https://www.example.com/holidays/abano-terme-holidays.html\n"
+ "https://www.example.com/holidays/crete/hersonissos/hotel-lovely-holidays.html\n"
+ "https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html\n"
+ "https://www.example.com/halkidiki-holidays.html\n"
+ "https://www.example.com/holidays/abano%20terme-holidays.html\n"
+ "https://www.example.com/holidays/abano-terme-holidays.html\n"
+ "https://www.example.com/holidays/abu-dhabi-all-inclusive-holidays.html\n"
+ "https://www.example.com/holidays/abu-dhabi-holidays.html\n"
+ "https://www.example.com/holidays/abu-soma-holidays.html\n"
+ "https://www.example.com/holidays/acharavi-holidays.html\n"
+ "https://www.example.com/holidays/achladies-holidays.html\n"
+ "https://www.example.com/holidays/aci-castello-holidays.html\n"
+ "https://www.example.com/holidays/acireale-holidays.html\n"
+ "https://www.example.com/holidays/acoteias-holidays.html\n"
+ "https://www.example.com/holidays/adana-holidays.html\n"
+ "https://www.example.com/holidays/adelianos-kampos-holidays.html\n"
+ "https://www.example.com/holidays/aegean-coast-holidays.html\n"
+ "https://www.example.com/holidays/afandou-holidays.html\n"
+ "https://www.example.com/holidays/afitos-holidays.html\n"
+ "https://www.example.com/holidays/africa-holidays.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}