re = /^[A-Za-z\u0E01-\u0E5B]+[\.]?[\u0020]?[A-Za-z\u0E01-\u0E5B]+$/
str = 'ณ.ระนอง'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end