package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Za-z\u0E01-\u0E5B]+[\.]?[\u0020]?[A-Za-z\u0E01-\u0E5B]+$`)
var str = `ณ.ระนอง`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}