$re = '/^[A-Za-z\u0E01-\u0E5B]+[\.]?[\u0020]?[A-Za-z\u0E01-\u0E5B]+$/';
$str = 'ณ.ระนอง';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);