import Foundation
let pattern = #"((\+66|0)(\d{1,2}\-?\d{3}\-?\d{3,4}))|((\+๖๖|๐)([๐-๙]{1,2}\-?[๐-๙]{3}\-?[๐-๙]{3,4}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
065-963-9928
088-992-6492
065-9926492
0659926492
02-700-9099
02-7009099
027009099
+66889926492
0212345678910
088-9926492
02-99264923
02-992-64923
๐๒๙๙๖๔๙๒๓
๐๒-๙๙๖-๔๙๒๓
๐๒-๙๙๖๔๙๒๓
๐๘๘๙๙๖๔๙๒๓
๐๘๘-๙๙๖๔๙๒๓
๐๘๘-๙๙๖-๔๙๒๓
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)