$re = '/((\+66|0)(\d{1,2}\-?\d{3}\-?\d{3,4}))|((\+๖๖|๐)([๐-๙]{1,2}\-?[๐-๙]{3}\-?[๐-๙]{3,4}))/m';
$str = '065-963-9928
088-992-6492
065-9926492
0659926492
02-700-9099
02-7009099
027009099
+66889926492
0212345678910
088-9926492
02-99264923
02-992-64923
๐๒๙๙๖๔๙๒๓
๐๒-๙๙๖-๔๙๒๓
๐๒-๙๙๖๔๙๒๓
๐๘๘๙๙๖๔๙๒๓
๐๘๘-๙๙๖๔๙๒๓
๐๘๘-๙๙๖-๔๙๒๓
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);