use strict;
my $str = '065-963-9928
088-992-6492
065-9926492
0659926492
02-700-9099
02-7009099
027009099
+66889926492
0212345678910
088-9926492
02-99264923
02-992-64923
๐๒๙๙๖๔๙๒๓
๐๒-๙๙๖-๔๙๒๓
๐๒-๙๙๖๔๙๒๓
๐๘๘๙๙๖๔๙๒๓
๐๘๘-๙๙๖๔๙๒๓
๐๘๘-๙๙๖-๔๙๒๓
';
my $regex = qr/((\+66|0)(\d{1,2}\-?\d{3}\-?\d{3,4}))|((\+๖๖|๐)([๐-๙]{1,2}\-?[๐-๙]{3}\-?[๐-๙]{3,4}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}