import Foundation
let pattern = #"(\d)(?=(?:\d{3})+$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123456789123456789"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)