$re = '/(\d)(?=(?:\d{3})+$)/';
$str = '123456789123456789';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;